[LMS]新規ウィンドウが開かず教材が実行できない(ポップアップブロックの解除)
カテゴリー | トラブルシューティング |
---|---|
製品 | Attain2 Attain3 smart FORCE |
バージョン | すべてのバージョン |
最終更新日 | 2015年2月3日 |
LMSから教材実行しようとした際、特定の環境下において教材が実行できない(教材ウィンドウが表示されない)現象が報告されています。
現象
Attain2/3やsmart FORCEなどのLMSから教材を起動しても、教材が実行されず何も起きない。
発生する環境
下記の環境において、現象が確認されています。
OS | Microsoft Windowsの各バージョン |
---|---|
ブラウザー | Microsoft Internet Explorerの各バージョン、Firefoxなど |
原因
Webブラウザー、またはブラウザーのツールバーに搭載されているポップアップブロック機能が働き、新規ウィンドウが開かないためです。
Attain2/3やsmart FORCEは、教材を起動する際、ブラウザーのウィンドウを新しく開いて実行します。そのためブラウザーの「ポップアップブロック」機能が有効になっていると、教材が起動しません。
ポップアップブロックとは
ホームページを開いたとき、またはユーザーのクリックなどにより、新しく開かれるウィンドウをポップアップ(ポップアップウィンドウ)と呼びます。
通常は適切なものですが、その一方で「危険性のあるポップアップ(不正プログラムが起動するもの)」「何度も勝手に表示されるような悪質なもの」がインターネット上に登場したため、それを防止する機能が主要なブラウザー、およびブラウザーのツールバーに搭載されました。これを総称してポップアップブロック機能、またはポップアップブロッカーと呼ばれています。
対策
下記手順を参考に、ポップアップブロックの機能を解除します。
- 注意事項
-
下記手順では「ポップアップブロックの機能を解除する」方法をご紹介しています。このほかに「個別のアドレスのみポップアップを許可する」こともできますので、詳細は各ソフトウェアのヘルプをご確認ください。
手順
Internet Explorer 7/8の場合
-
ツールバー右端の[ツールボタン(歯車のアイコン)]アイコンをクリックします。
-
[ポップアップ ブロック]から[ポップアップ ブロックを無効にする]を選びます。
これでポップアップブロックが解除されます。
ブロックを有効にする場合は、再度同じメニューを開き[ポップアップ ブロックを有効にする]を選びます。
-
開いているブラウザーをいったんすべて閉じて、アプリケーションを開き直します。
Internet Explorer 9以降の場合
-
ツールバー右端の[ツールボタン(歯車のアイコン)]アイコンをクリックし、[インターネットオプション]をクリックします。
-
インターネットオプションダイアログが開くので、
- [プライバシー]を選択し
- [ポップアップブロックを有効にする]のチェックを外します。
Firefox の場合
-
- ツールバー右端の [メニューを開く (3本線のアイコン)]をクリックし、
- [オプション]をクリックします。
-
オプションダイアログが開きます。
- [コンテンツ] を選択し、
- [ポップアップウィンドウをブロックする]のチェックを外します。
Safari(Mac OSX)の場合
-
メニューバーの[Safari]から [環境設定]を選びます。
[インターネットオプション]をクリックします。
-
一般タブが開くので、
- [セキュリティー]を選択し、
- [ポップアップウィンドウを開かない]のチェックを外します。
Google Chromeの場合
-
- ツールバー右端の[メニューを開く (3本線のアイコン)]をクリックし、
- [設定]をクリックします。
-
設定画面が表示されます。
一番下までスクロールし、 [詳細設定を表示]をクリックします。
-
プライバシー項目の[コンテンツの設定]のボタンをクリックします。
-
[コンテンツ設定]の画面が表示されます。
[ポップアップ]の項目の[すべてのサイトに対してポップアップ表示を許可する]を選択します。
[ 完了 ]ボタンをクリック します。
Yahoo!ツールバーの場合
Yahoo!ツールバーは、最新のバージョンではポップアップブロック(ポップアップ ブロッカー)の機能を廃止しています。最新版に更新のうえ、ご利用ください。