[smart FORCE]
Google Chromeの最新版(Ver. 83)、
Edgeの最新版( Chromium 版 Edge )で
学習履歴が正常に更新されない件について
カテゴリー | トラブルシューティング |
---|---|
製品 | smart FORCE |
発生するブラウザ | Chrome Ver. 83.XX Edge Ver. 83.XX |
最終更新日 | 2020年6月3日 |
smart FORCEで学習履歴が正常に更新されない問題が報告されています。
現象
Chromeの最新版(Ver. 83)で 学習を行うと、正しく成績が反映されない問題を確認しています。
またEdgeの最新版( Chromium 版 Edge )でも、同様の現象が発生しています。
原因
Chrome の仕様変更があり、ブラウザーウィンドウを閉じる際に行う http 通信(同期 XMLHttpRequest)をブロックしてしまい、学習履歴がデータベースに記録されなくなっています。
Edge の最新版( Chromium 版 Edge )も、Chrome エンジンを利用しているので、同様の現象が発生します。
一時的な対応
暫定ではございますが事象を回避できる2つの方法をご報告します。
1. Google Chrome や Microsoft Edge の設定を変更する
Google Chrome の場合
1. Chromeで下記のアドレスを入力
chrome://flags/#allow-sync-xhr-in-page-dismissal
2. 「Allows synchronous XHR requests in page dismissal」の設定を[Default]から[Enabled]に変更し、[Relaunch]ボタンを押下する
![「Allows synchronous XHR requests in page dismissal」の設定を[Default]から[Enabled]に変更](image/smart-force-chrome-edge/chrome.jpg)
Microsoft Edge の場合
1. Edge で下記のアドレスを入力
edge://flags/#allow-sync-xhr-in-page-dismissal
2. 「Allows synchronous XHR requests in page dismissal」の設定を[Default]から[Enabled]に変更し、[Relaunch]ボタンを押下する
![[Default]から[Enabled]に変更](image/smart-force-chrome-edge/edge.jpg)
なお、この対処方法も将来利用できなくなる可能性があります。
2. 下記のブラウザーをご利用頂く
Internet Explorer 11、FireFox、Safari(MacOS)では、正常に受講頂けます。
解決方法
解決方法については現在調査中でございます。
ご利用の皆さまには大変ご迷惑をおかけ致しまして申し訳ございませんが、何卒よろしくお願いします。
- 関連リンク